Category

XPresso Preset

Tags

Christmas, Light, Rig, Spline

Developer

Daniel Couto

Xmas Lights v.5.1

Xmas Lights consists of 5 rigs that are added to Cinema 4D’s Content Library. They enable you to drop a string of Christmas Lights on any spline. The 5 rigs each feature a different bulb – Pine Cone, Ping, Retro, Sno-Globe and Star.


Supported C4D releases: R11.5, R12, R13, R14, R15, R16
Required C4D modules: -
$ 35 
Buy now Add to cart

Xmas Lights 5.1 Features:


Drop any spline into the rig and a string of Xmas Lights will follow it. - 3 animation modes - 5 different bulbs - works with open and closed splines as well as spline primitives

Discussion about this product

  1. Reply
    kris waterman on November 27, 2014 at 1:23 am

    Hi, I just bought this plugin today, but when I try to save the/a project using the plugin I get a error message, missing Bass/Mid/Treb. Do I just delete the Sound Control group to avoid this error?

    • Dan Couto on November 27, 2014 at 2:03 pm

      Yes, for now, just delete the Sound Control. I will look into this and get back to you.

    • Dan Couto on November 27, 2014 at 2:25 pm

      I can’t duplicate the error. Bass, Mid and Trep are sound effectors that come with C4D so they should be saving with the file.

  2. Reply
    anthony b on November 25, 2014 at 8:49 am

    hey. just purchased this. neat plugin. but when i go to move the position of the whole thing within my scene(xmas lights 5.1 retro bulb) , it seems to just resize elements instead of moving the position. Any help with this? im using r12 btw. Thanks

    • Dan Couto on November 27, 2014 at 2:02 pm

      Please email me your scene file and I will see what I can do. dc@dancouto.com

  3. Reply
    carson on November 19, 2014 at 4:03 am

    Hi,
    Love this plugin. I think there’s a bug with the TWINKLE working when using multiple instances in the same scene. Any ideas or workarounds?

    • Dan Couto on November 20, 2014 at 11:48 am

      Can you be more specific or better yet, email me your scene file and a description of the problem? Thanks.

  4. Reply
    Willem on November 5, 2014 at 5:42 pm

    Hi!

    Has anyone tested this rig in R16?

    Thanks!

    • Dan Couto on November 20, 2014 at 11:47 am

      It is an XPresso rig so it works in R16.

  5. Reply
    Pascal on December 20, 2013 at 4:44 pm

    Does this rig also work with dynamics?

  6. Reply
    Dan Couto on November 4, 2013 at 6:23 pm

    It hasn’t been fully tested with R15 but so far there have not been any issues.

  7. Reply
    jont on November 4, 2013 at 6:03 am

    Hi. Just I bought the rig. Thanks for making it. I noticed you didn’t indicate compatibility with R15. Are there any issues with R15 and your rig?

  8. Reply
    arkat on October 19, 2013 at 9:31 pm

    I’ve bought the latest version yesterday and I discovered that the lights were emitting white light instead of colored light like we would expect. The “visible light” effet is the proper colour though, which makes it even stranger. Is this behaviour normal ? What can I do to change it ?
    BTW, I am running R13.
    Thanks.

    Feature request : a way to reduce the complexity of the models, so as to reduce polygon count. I can go in there and change the profile shape of the cord for example, but being able to do this from your interface would be even better and this could apply to all objects. It could be called “LOD” or something.

    • arkat on October 20, 2013 at 3:36 am

      Solution to emit colored lighting : select all the lights and uncheck “Use Gradient” in the “details” tab. To compensate for the loss of brightness, you can increase the “Radius/Decay” setting right above.

    • Dan Couto on October 21, 2013 at 2:32 pm

      The default is colored light emission. I will add a complexity slider in the next version.

  9. Reply
    Marty Morales on September 26, 2013 at 4:11 am

    Hey! buddy, I bough Xmas Light v.3 from you in February of this year. I don’t recalled which e-mail I have used, because I have a few. It could been ( vailfox2007@yahoo.com ) or ( tucsonfox07@yahoo.com ) or fox4you2012@yahoo.com. Can you please send me the Update if their one. My Xmas Light file said is a v3 don’t know. The reason I think this is a older version is, because I couldn’t find the Animation settings…:) Please respond to me to my at fox4you2012@yahoo.com. I will take a picture shoot,so that you can see for your self what I mean. Did you have Update this file Xmas Light lately? Thanks for your time.

  10. Reply
    Daniel on December 18, 2012 at 7:51 am

    Unfortunately, no.

  11. Reply
    Imran on December 18, 2012 at 4:17 am

    Does it work with Vray render engine…?

  12. Reply
    Leandro on December 17, 2012 at 11:01 pm

    Thank you very much Daniel… working fine!!!

  13. Reply
    Daniel on December 14, 2012 at 2:43 pm

    Version 5.1 is ready for you. You can email me at dc@dancouto.com and I will send it to you.

    Fixed:
    Light position not in sync with bulb position when bulbs scaled.

  14. Reply
    Leandro on December 14, 2012 at 12:35 am

    Hi friend, I am facing a problem with the plugin, when I reduce the size of the bulb, the light keeps on previous position, outside the lamps, and the cables are also not fitting, are out of position. What can I do to fix? thank you

    • Daniel on December 14, 2012 at 7:57 am

      Working on a fix that will reposition the lights. I’ll have it ready tomorrow. As to the cables, advance your animation one frame, then bring it back to zero and that should fix the problem. There is some Xpresso lag but I just tested the rig and the cables will always follow the number of lights. If you are doing a drastic resize, you may need to reposition the cord height inside the plastic housing as well as it’s width. I will post here as soon as I’ve uploaded the fix.

Ask the developer

This section is only for questions concerning this product,
feature requests and bug reports. Please be friendly.


* required fields