Category

Python Plugin

Tags

Particle, Spline, Tracer

Developer

Dominik Ruckli

RayConnector v.1.0

The Ray-Connector is a python-plugin which allows you to connect Thinking Particles with Splines. Features: adjust the maximal connection-distance between the particles; adjust the number of spline-connections of each particle; animatable settings; renderable with Hair or Sweep-NURBS; converting to an editable Spline-Object


Supported C4D releases: R14
Required C4D modules: Thinking Particles
it's free!
Download now

Discussion about this product

  1. Reply
    Malde on April 27, 2014 at 6:02 am

    ¡hello !
    I just wanted to know how you installed the plugin on my pc? in that folder?

  2. Reply
    Tim rice on April 2, 2014 at 9:16 am

    Hi,
    Thanks so much for this amazing Plug in! i’ve used it a lot with the matrix object! But I do continually have an issue when clicking “initial”. Generally when opening projects i have to RE-Initial. It will also often connect to different TP Groups. This only happens with initial and there is a workaround with animating initial on after the 1st frame. Just wanted you know! Thanks so much again, I really love using it!

    • Dominik on April 3, 2014 at 10:23 am

      Hi Tim,
      i know there are some bugs, but nice to see the workarounds of you guys! I think i dont develop the plugin further but there is a new plugin in my pipeline which also can do fun stuff ;)

  3. Reply
    Martin L on January 30, 2014 at 12:06 am

    I cannot get any material to the ray connector. Is there a special tag or something?

    • Dominik on February 17, 2014 at 7:30 pm

      Hi Martin,
      The RayConnector generates splines, so it works just with Hair-Materials. If you want normal materials, you have to put the RayConector in a Sweep-Nurbs

  4. Reply
    Eric Jordan on December 18, 2013 at 4:48 am

    Hello,

    Im using RayConnector in C4D R15, and the connector lines render fine in the viewport, but when I go to do a file render, the connectors don’t render (while everything else in the scene does). Im using a hair material with just the color attribute active. Any ideas what could cause this?

    Thanks so much,
    Eric Jordan

  5. Reply
    Goran on November 2, 2013 at 10:10 pm

    Hello dude. I have just download Ur RayConnector, but seems to me Houston still have a problem. Cause I have doing this TP for the first time, SO I have follow Ur tutorial. That is OK, till I start to add Random and Matrix to TP-PGroup panel. Doesn’t want to accept it.. So I figure it out, watched again and agin Ur tut, and I can see that U have TAB for TP (bottom – middle screen on Ur tut), I cant find it dude… So this became a nightmare to me, I cant discover anything new cause Im stuck with this problem. So if You can just help me I will ask dear God to give U strength to get with new client for 50 more Years :)

    TNX in advance.

    Goran

  6. Reply
    Yun on October 15, 2013 at 10:34 am

    Hi there, I have tested this plugin, works fine. However tried with a render with hair material, doesn’t show up any results. Please let me know what this happens.

    • Dominik on November 4, 2013 at 12:53 pm

      Hi Yun,
      i cant figure it out why it sometimes work and sometime not. Sorry im a designer an not a hardcore coder so its hard for me to find a solution.
      BUT!!! i find a plugin that does the same as the ray-connector and much more, this plugin is also written in C++ not in Python so the performance is much better! And it is FREE :)
      http://www.genemagtoto.com/c4dplugins/
      >> “Uebertracer”

  7. Reply
    Justin on August 26, 2013 at 6:33 pm

    would there be a specific reason i get a perfect viewport render but picture viewer shows nothing?

    • Dominik on August 31, 2013 at 1:09 am

      Oh looks like a bug, funny that i dont recognized till yet. I’ll try to remove that in the next release.
      For now animation works and if you wanna render a still frame make it editable.

    • rimax420 on September 18, 2013 at 7:48 pm

      Thank you for this awesome plugin!
      Is there any News on when the Picture Viewer Render Bug is fixed?

    • rimax420 on September 18, 2013 at 8:20 pm

      Just found a solution for the Picture Viewer Bug:
      Use the moGraph Tracer or UberTracer and Trace the Ray Connector Object.
      Works like a charm :)

    • Dominik on September 19, 2013 at 12:15 pm

      Ah great. c4d is so brilliant, there is always a solution :) .

  8. Reply
    tobias leo on August 26, 2013 at 12:07 pm

    havin trouble rendering to the picture viewer.
    But when i make the ray connector editable (single frame) it works.
    Please advise

    • Dominik on August 31, 2013 at 1:10 am

      Is a Bug :( . I’ll try to remove that in the next release.

  9. Reply
    DIEGO on August 18, 2013 at 11:56 am

    hi
    I would like to know how you made the last part of your video, where you used the particle emitter.
    Thanks
    Diego

    • Dominik on August 31, 2013 at 1:18 am

      Hi, its just the normal TP-Emitter from the presets an an TP-PlanerWind also from the presets.
      Go to you Content-Browser, then “Presets > Studio > Simulation > Thinking Particles > Presets”. In the folder “Emitters” use the “TP Standart Emitter” and in the folder “Effectors” use the “TP Planer Wind” for the Turbulence.

    • Dominik on August 31, 2013 at 1:21 am

      “…presets AND A TP-PlanerWind also…” sorry ;)

  10. Reply
    MJM on August 14, 2013 at 7:38 pm

    Thank you for that Plugin, can you do in depth demo in English or at least has close caption

    • Dominik on August 31, 2013 at 1:29 am

      Hi, sorry i have a lot of client-work at the moment and there’s no time for free projects :( … but i try to develop further and do a better description with a new releas. But if you have a specific question write me a mail or ask in here.

Ask the developer

This section is only for questions concerning this product,
feature requests and bug reports. Please be friendly.


* required fields