Category

Python Plugin

Tags

Animation, Rig, Toy, Tracking, Workflow

Developer

Ahmed El-Hofy

Easy Car Rig v.2.0.5

Easy Car Rig v2.0.5 is the newest version of Easy Car Drive Tool, which is a plugin for animating cars. V2.0.5 is small bug fix version but it’s a very important update. It fixes the rotating calipers bug. It also has some improvements to the rigging process.


Supported C4D releases: R13, R14, R15
Required C4D modules: Dynamics
it's free!
Download now

Copyright


Developer : Ahmed El-Hofy : www.ahmedelhofy.com

Tires not appearing in render :: FIX


IF the tires of the car are not appearing in the render
go here
http://www.ahmedelhofy.com/2013/03/Fix-for-Easy-Car-Rig-v2.html

Discussion about this product

  1. Reply
    Andreas Müller-Rhein on March 11, 2014 at 8:54 pm

    Hi,
    today I used “Easy car Rig” to rig an Audi S8 for a sequence for my Demo Reel.
    I am working as a Motion Designer and VFX Compositing Artist in Germany. I spent 6 hours to solve a serious problem with Easy-Car-Rig, but without success. Thats the reason why I decided to write you. The rigging of the car was successfull. But when I use the steering parameters, the wheels beginn to to spin around every axis. It looks very awful. I tried everything to get rid of the problem. Nothing helps. The axis are also all in the right position. If you like, I can send you the project file. I hope you know whats going on there. I guess its a bug in the Plug-in.
    Best regards, Andreas

    • Ahmed El-Hofy on March 13, 2014 at 12:56 pm

      Hey, this is a C4D bug, it’s very easy solve just make sure that the steering is set as 0 when u start the simulation, then animate it after that..

      Thanks,
      Ahmed

  2. Reply
    Charlotte R. on May 10, 2013 at 3:59 pm

    Hi everybody,
    thanks for this wonderful plugin, Ahmed.
    I was just wondering..I tried all the morning to rig my car but something wrong is happening, when I want to turn right or left,front wheels are going like if they were warped ><. I've no steering wheel for the moment, and all pivot are at the right place..Thanks!
    Charlotte

  3. Reply
    Giso Spijkerman on April 25, 2013 at 3:23 pm

    Hello there!

    My wheels are rotating, but the car doesn’t move.

    Also, I can’t turn off the default floor.

    Am I doing something wrong?

    Thnks!
    Giso

    • Ahmed El-Hofy on April 26, 2013 at 1:03 pm

      Please Watch the Demo Video carefully.
      To turn off the default floor, in the editing mode, turn off “Use Default Floor” and turn on “Hide Floor in Viewport” & “Hide Floor in Render”

      Concerning the car doesn’t move be sure you have made a body dummy object, parented it to the plugin using the body object option found in the editing mode, also you need to add a dynamic tag on the body dummy object

      Thanks,
      Ahmed

    • Giso Spijkerman on April 29, 2013 at 12:54 pm

      hi Ahmed,

      thanks for your reply.

      I guess there is something else wrong…

      because ofcourse i did every step carefully as descriped in your video…

      but the floor stays in the viewport and render, and my car is under a dummy object with a dynamics tag on the dummy.

      i have r13 studio

      thnks Ahmed. I thought it could be the friction (because the wheel do rotate, but the car doesnt move) but that doesnt work either.

      Could you possibly send me a working c4d scene file with a free car driven by your plugin? Just to compare or see if it works here?

      best regards
      Giso

    • Ahmed El-Hofy on April 29, 2013 at 3:31 pm

      When you disable the floor, it will be still visible but it will no longer be a dynamic collider object.
      and You will still have options to hide it,
      and the problem with the Wheels, You might havn’t linked the dummy object with the plugin or haven’t added a dynamic tag on the dummy object

    • Giso Spijkerman on April 29, 2013 at 4:37 pm

      sry, my bad, problem solved…. thnks!

    • Ahmed El-Hofy on April 29, 2013 at 10:51 pm

      Good to see you fixed it,
      Have Fun :)

  4. Reply
    Chris on March 28, 2013 at 3:00 am

    hello I love you plugin, but everytime I try to render it the tires disappear. Please help
    Thanx

  5. Reply
    trekki on March 26, 2013 at 2:09 pm

    Very cool, thank.
    Works fine …

Ask the developer

This section is only for questions concerning this product,
feature requests and bug reports. Please be friendly.


* required fields